aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-10 17:07:14 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-11 08:25:56 -0700
commitd8eeb57e4404caf8753611c0709a9cef8f756c8b (patch)
tree910780d15aca8e259582b2488e91bc69b530d460 /meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb
parent6a1ee0d98411fbe58304b48d978da9fad9039d14 (diff)
downloadmeta-openembedded-contrib-d8eeb57e4404caf8753611c0709a9cef8f756c8b.tar.gz
python3-humanize: Upgrade 3.4.1 -> 3.5.0
Upgrade to release 3.5.0: - Add intword processing for thousands - Update translation .po files with 'thousand' - Remove generated translation binaries from repo Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb b/meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb
new file mode 100644
index 0000000000..866079105e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanize_3.5.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[sha256sum] = "a0474226e1494923f9106758e11f0c3bb4dbe5e7d84388fa78f90eb7713b5d65"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-setuptools-scm-native \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"