aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-huey_2.3.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-12 13:27:23 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commit1d0f8442f50ea11daa5bd91e9f785411db248593 (patch)
tree93cfb87576753b7ff5bce5bba9122ca350d5b6e4 /meta-python/recipes-devtools/python/python3-huey_2.3.0.bb
parent0cd303083793b0799268f9bca43d0b9137d9287f (diff)
downloadmeta-openembedded-contrib-1d0f8442f50ea11daa5bd91e9f785411db248593.tar.gz
python3-huey: Upgrade 2.2.0 -> 2.3.0
Upgrade to release 2.3.0: - Use monotonic clock for timing operations within the consumer. - Ensure internal state is cleaned up on file-lock when released. - Support passing around TaskException as a pickled value. - Set the multiprocessing mode to "fork" on MacOS and Python 3.8 or newer. - Added option to enforce FIFO behavior when using Sqlite as storage. - Added the on_shutdown handler to djhuey namespace. - Ensure exception is set on AsyncResult in mini-huey. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-huey_2.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-huey_2.3.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-huey_2.3.0.bb b/meta-python/recipes-devtools/python/python3-huey_2.3.0.bb
new file mode 100644
index 0000000000..f70a349fd5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-huey_2.3.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "a little task queue for python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5cac039fcc82f01141cc170b48f315d4"
+
+PYPI_PACKAGE = "huey"
+
+SRC_URI[md5sum] = "aa9f2a8f54cb68c62690c5e28589f49c"
+SRC_URI[sha256sum] = "76978840a875607cd77c283c4ebf3ea5071b2ec06a1ac428d63be0d88f1e7070"
+
+inherit pypi setuptools3
+