aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-25 13:15:41 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-28 09:02:47 -0700
commitc948d46a547f08ce885b092f077f7d2b75a909eb (patch)
tree41d61b89ebace9141656687f3c9d4d131b3d2131 /meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb
parent9ffef2b0dcc4a486dde7169573fbabf95cabf19a (diff)
downloadmeta-openembedded-contrib-c948d46a547f08ce885b092f077f7d2b75a909eb.tar.gz
python3-httplib2: Fix runtime dependencies
Add python3-compression, python3-netclient and python3-pyparsing as runtime dependencies. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb b/meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb
index a16f8d9d20..122b4bd8b7 100644
--- a/meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb
+++ b/meta-python/recipes-devtools/python/python3-httplib2_0.19.1.bb
@@ -7,3 +7,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=56e5e931172b6164b62dc7c4aba6c8cf"
SRC_URI[sha256sum] = "0b12617eeca7433d4c396a100eaecfa4b08ee99aa881e6df6e257a7aad5d533d"
inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pyparsing \
+"