aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-20 16:54:25 +0800
committerKhem Raj <raj.khem@gmail.com>2024-02-20 08:46:27 -0800
commit8f1c0c4d64182dceb781ff75f0031cae6b9f3f8b (patch)
treed17fe6bd823d31a9ab611e4faec3e7b3a9d022ec /meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb
parente4e0d366b938c499d1490dc8013e465c57f53a28 (diff)
downloadmeta-openembedded-contrib-8f1c0c4d64182dceb781ff75f0031cae6b9f3f8b.tar.gz
python3-httpcore: upgrade 1.0.2 -> 1.0.3
Changelog: ========== -Fix support for async cancellations. -Fix trace extension when used with socks proxy. -Fix SSL context for connections using the "wss" scheme Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb b/meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb
new file mode 100644
index 0000000000..203bfd48a1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httpcore_1.0.3.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A minimal low-level HTTP client."
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1c1f23b073da202e1f4f9e426490210c"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "5c0f9546ad17dac4d0772b0808856eb616eb8b48ce94f49ed819fd6982a8a544"
+
+DEPENDS += "\
+ python3-hatch-fancy-pypi-readme-native \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[http2] = ",,,python3-h2"
+PACKAGECONFIG[socks] = ",,,python3-socksio"
+PACKAGECONFIG[asyncio] = ",,,python3-anyio"
+# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
+# If somebody needs this please feel free to add python3-trio and enable the
+# packageconfig below:
+#PACKAGECONFIG[trio] = ",,,python3-trio"
+
+RDEPENDS:${PN} += "\
+ python3-certifi \
+ python3-h11 \
+"