aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-22 15:15:53 -0700
committerKhem Raj <raj.khem@gmail.com>2021-03-24 08:50:45 -0700
commitc8bd8cd1726571d983730997d7f0d7f01102dbad (patch)
treecbbb5c4a7758581b4e506fd351adf7b6c01bee8e /meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
parent4cdb2458a962550359e812d461e5b36d3c2f321c (diff)
downloadmeta-openembedded-contrib-c8bd8cd1726571d983730997d7f0d7f01102dbad.tar.gz
python3-hexdump: Move cleanup_hexfile into install_append
This fixes error seen during staging phase run.sysroot_stage_all.902827: line 182: cd: TOPDIR/build/tmpfs/work/core2-32-yoe-linux-musl/python3-hexdump/3.3-r0/image/usr/share: No such file or directory this happens because D is being altered outside pseudo's context, and alterning D is done after do_install ends so its likely going to race as well with subsequent functions and change pseudo context too Fixes occasionally seen build failures on autobuilders Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-hexdump_3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-hexdump_3.3.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb b/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
index cb04e17dfd..5325048039 100644
--- a/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
@@ -19,9 +19,7 @@ S = "${WORKDIR}"
BBCLASSEXTEND = "native nativesdk"
-do_cleanup_hexfile() {
+do_install_append() {
rm ${D}${datadir}/data/hexfile.bin
rmdir ${D}${datadir}/data ${D}${datadir}
}
-
-addtask cleanup_hexfile before do_package after do_install