aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2021-01-22 16:15:37 +1030
committerKhem Raj <raj.khem@gmail.com>2021-01-25 14:34:06 -0800
commit1ac1e523cccb74f5f443922be0b6a7c2933f5f7e (patch)
treee4c02f078699802a153addfa93c5735bd8039e8d /meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
parent2dfe32fd822c8d7dcec4d4046598969d51006a88 (diff)
downloadmeta-openembedded-contrib-1ac1e523cccb74f5f443922be0b6a7c2933f5f7e.tar.gz
meta-python: Add hexdump package
The hexdump package appears to be abandoned, but it's used as the dependency of another project I'm packaging. Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-hexdump_3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-hexdump_3.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb b/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
new file mode 100644
index 0000000000..cb04e17dfd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-hexdump_3.3.bb
@@ -0,0 +1,27 @@
+SUMMARY = "view/edit your binary with any text editor"
+
+# The homepage listed on pypi is [1] but the repository has been removed.
+# Instead, set the homepage to pypi.
+#
+# [1] https://bitbucket.org/techtonik/hexdump/
+HOMEPAGE = "https://pypi.org/project/hexdump/"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
+
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi distutils3
+
+SRC_URI[sha256sum] = "d781a43b0c16ace3f9366aade73e8ad3a7bd5137d58f0b45ab2d3f54876f20db"
+
+S = "${WORKDIR}"
+
+BBCLASSEXTEND = "native nativesdk"
+
+do_cleanup_hexfile() {
+ rm ${D}${datadir}/data/hexfile.bin
+ rmdir ${D}${datadir}/data ${D}${datadir}
+}
+
+addtask cleanup_hexfile before do_package after do_install