aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-02-15 01:04:48 -0500
committerKhem Raj <raj.khem@gmail.com>2019-02-17 12:21:27 -0800
commitf6a3e4b5632460e66c5f8105d1c51e49c68a5b8d (patch)
treeb35e9608c009258666241d84769f490cf3c2a597 /meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb
parent19dee696a2c246c503ec41c2ff8808cc3cd127ce (diff)
downloadmeta-openembedded-contrib-f6a3e4b5632460e66c5f8105d1c51e49c68a5b8d.tar.gz
python3-h5py: add version 2.9.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb
new file mode 100644
index 0000000000..bca7757ad8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py_2.9.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python. "
+HOMEPAGE = "https://www.h5py.org/"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=795ecad0d261c998cc526c84a822dff6"
+
+SRC_URI = "git://github.com/h5py/h5py.git \
+ file://0001-cross-compiling-support.patch \
+ "
+SRCREV ?= "8d96a14c3508de1bde77aec5db302e478dc5dbc4"
+
+inherit setuptools3
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "python3-pkgconfig-native \
+ python3-cython-native \
+ python3-numpy-native \
+ python3-six-native \
+ python3 \
+ hdf5 \
+ "
+
+RDEPENDS_${PN} = "python3-numpy \
+ python3-six \
+ "
+
+export HDF5_VERSION="1.8.19"