aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-02 13:48:19 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:20:11 -0700
commit259b20be6420281d2df3bfadd176d603592c89cc (patch)
treeb3474fc65ae0ec4dc12f7507939e9122624c1537 /meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
parent3659e48241bb9a54c734bf5ca613a2901a483183 (diff)
downloadmeta-openembedded-contrib-259b20be6420281d2df3bfadd176d603592c89cc.tar.gz
python3-h5py: Upgrade 2.9.0 -> 2.10.0
Inherit pypi. Use LICENSE for LIC_FILES_CHKSUM. Upgrade to release 2.10.0, for details: http://docs.h5py.org/en/stable/whatsnew/index.html Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
new file mode 100644
index 0000000000..3904abbb48
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
+HOMEPAGE = "https://www.h5py.org/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
+
+SRC_URI[md5sum] = "504b595237409ab766fbbe568e60a080"
+SRC_URI[sha256sum] = "84412798925dc870ffd7107f045d7659e60f5d46d1c70c700375248bf6bf512d"
+
+SRC_URI_append = " \
+ file://0001-cross-compiling-support.patch \
+ "
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "python3-pkgconfig-native \
+ python3-cython-native \
+ python3-numpy-native \
+ python3-six-native \
+ python3 \
+ hdf5 \
+ "
+
+RDEPENDS_${PN} = "python3-numpy \
+ python3-six \
+ "
+
+export HDF5_VERSION="1.8.21"