aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-22 19:15:10 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-24 09:07:24 -0800
commit606a07f6c5fed53846de53acbbf9ed29e481f395 (patch)
tree6c37e3d2bbbf571310685aff933ef37bcb6e5e24 /meta-python/recipes-devtools/python/python3-h5py
parentc72839e6a4fb5a3da77dcfc23ed3f8ce18ed509b (diff)
downloadmeta-openembedded-contrib-606a07f6c5fed53846de53acbbf9ed29e481f395.tar.gz
python3-h5py: Upgrade 2.10.0 -> 3.1.0
Upgrade to release 3.1.0: - Fix using bytes as names for :meth:`~Group.create_dataset` and  :meth:`~Group.create_virtual_dataset`. - Fix writing data as a list to a dataset with a sub-array data type. - Preserve endianess in Cython dataset Reader - If pytest is missing pytest-mpi then it will now fail immediately with a clear warning message - Fix a test which was failing on big-endian systems Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch47
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch15
3 files changed, 35 insertions, 55 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch
deleted file mode 100644
index 8c0b914326..0000000000
--- a/meta-python/recipes-devtools/python/python3-h5py/0001-cross-compiling-support.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 364fd0906efa349ea44a761820408dcf6b2b8726 Mon Sep 17 00:00:00 2001
-From: Hongxu Jia <hongxu.jia@windriver.com>
-Date: Tue, 29 Jan 2019 17:08:32 +0800
-Subject: [PATCH] cross compiling support
-
-Remove useless dirs
-
-Upstream-Status: Inappropriate [oe specific]
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
----
- setup_build.py | 4 ----
- setup_configure.py | 2 +-
- 2 files changed, 1 insertion(+), 5 deletions(-)
-
-diff --git a/setup_build.py b/setup_build.py
-index c0e9a28c..ffd3bef7 100644
---- a/setup_build.py
-+++ b/setup_build.py
-@@ -55,10 +55,6 @@ if sys.platform.startswith('win'):
- ('_HDF5USEDLL_', None),
- ('H5_BUILT_AS_DYNAMIC_LIB', None)
- ])
--else:
-- FALLBACK_PATHS['include_dirs'].extend(['/opt/local/include', '/usr/local/include'])
-- FALLBACK_PATHS['library_dirs'].extend(['/opt/local/lib', '/usr/local/lib'])
--
-
- class h5py_build_ext(build_ext):
-
-diff --git a/setup_configure.py b/setup_configure.py
-index 5576775e..75f4141e 100644
---- a/setup_configure.py
-+++ b/setup_configure.py
-@@ -206,7 +206,7 @@ def autodetect_version(hdf5_dir=None):
- default_path = 'libhdf5.so'
- regexp = re.compile(r'^libhdf5.so')
-
-- libdirs = ['/usr/local/lib', '/opt/local/lib']
-+ libdirs = []
- try:
- if pkgconfig.exists("hdf5"):
- libdirs.extend(pkgconfig.parse("hdf5")['library_dirs'])
---
-2.17.1
-
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
new file mode 100644
index 0000000000..4881b023c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
@@ -0,0 +1,28 @@
+From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Mon, 22 Feb 2021 18:42:43 +0200
+Subject: [PATCH] setup.py: Fix numpy version
+
+Fix numpy version to ensure bitbake will find the pip package.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 7dbe583..6602c97 100755
+--- a/setup.py
++++ b/setup.py
+@@ -49,7 +49,7 @@ SETUP_REQUIRES = [
+ f"Cython >=0.29; python_version<'3.8'",
+ f"Cython >=0.29.14; python_version>='3.8'",
+ ] + [
+- f"numpy =={np_min}; python_version{py_condition}"
++ f"numpy >={np_min}; python_version{py_condition}"
+ for np_min, py_condition in NUMPY_MIN_VERSIONS
+ ]
+
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch
index da95ee7af5..d0c2ece19b 100644
--- a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch
+++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch
@@ -1,6 +1,6 @@
-From b5d5a7efc7aaa2be830731001ed17c5b71bcefb1 Mon Sep 17 00:00:00 2001
+From 1a46082d0889a784037952c4da0cde3822849032 Mon Sep 17 00:00:00 2001
From: Mingli Yu <mingli.yu@windriver.com>
-Date: Fri, 29 Jan 2021 02:33:06 +0000
+Date: Thu, 28 Jan 2021 18:44:10 -0800
Subject: [PATCH] setup_build.py: avoid absolute path
Prevent absolute path from ending up in the egg-info SOURCES.txt.
@@ -8,15 +8,17 @@ Prevent absolute path from ending up in the egg-info SOURCES.txt.
Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/1803]
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+
---
setup_build.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup_build.py b/setup_build.py
-index ffd3bef..fb196c0 100644
+index 3c7c7ad..d824bdd 100644
--- a/setup_build.py
+++ b/setup_build.py
-@@ -20,7 +20,7 @@ import api_gen
+@@ -21,7 +21,7 @@ from setup_configure import BuildConfig
def localpath(*args):
@@ -24,7 +26,4 @@ index ffd3bef..fb196c0 100644
+ return op.join(*args)
- MODULES = ['defs','_errors','_objects','_proxy', 'h5fd', 'h5z',
---
-2.29.2
-
+ MODULES = ['defs', '_errors', '_objects', '_proxy', 'h5fd', 'h5z',