aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-22 19:15:10 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-24 09:07:24 -0800
commit606a07f6c5fed53846de53acbbf9ed29e481f395 (patch)
tree6c37e3d2bbbf571310685aff933ef37bcb6e5e24 /meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
parentc72839e6a4fb5a3da77dcfc23ed3f8ce18ed509b (diff)
downloadmeta-openembedded-contrib-606a07f6c5fed53846de53acbbf9ed29e481f395.tar.gz
python3-h5py: Upgrade 2.10.0 -> 3.1.0
Upgrade to release 3.1.0: - Fix using bytes as names for :meth:`~Group.create_dataset` and  :meth:`~Group.create_virtual_dataset`. - Fix writing data as a list to a dataset with a sub-array data type. - Preserve endianess in Cython dataset Reader - If pytest is missing pytest-mpi then it will now fail immediately with a clear warning message - Fix a test which was failing on big-endian systems Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
new file mode 100644
index 0000000000..4881b023c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
@@ -0,0 +1,28 @@
+From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Mon, 22 Feb 2021 18:42:43 +0200
+Subject: [PATCH] setup.py: Fix numpy version
+
+Fix numpy version to ensure bitbake will find the pip package.
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 7dbe583..6602c97 100755
+--- a/setup.py
++++ b/setup.py
+@@ -49,7 +49,7 @@ SETUP_REQUIRES = [
+ f"Cython >=0.29; python_version<'3.8'",
+ f"Cython >=0.29.14; python_version>='3.8'",
+ ] + [
+- f"numpy =={np_min}; python_version{py_condition}"
++ f"numpy >={np_min}; python_version{py_condition}"
+ for np_min, py_condition in NUMPY_MIN_VERSIONS
+ ]
+