aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-29 12:20:21 +0300
committerKhem Raj <raj.khem@gmail.com>2021-03-30 09:04:35 -0700
commitea648569cc804618bd41b91d62140e17cb82a998 (patch)
tree64f1c3f1109f6ab639af4718393d35bc453b60ac /meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
parent496d23539dcd675655c040fa7957fb542b27c38e (diff)
downloadmeta-openembedded-contrib-ea648569cc804618bd41b91d62140e17cb82a998.tar.gz
python3-gunicorn: Upgrade 20.0.4 -> 20.1.0
Upgrade to release 20.1.0: - document WEB_CONCURRENCY is set by, at least, Heroku - capture peername from accept: Avoid calls to getpeername by capturing the peer name returned by accept - log a warning when a worker was terminated due to a signal - fix tornado usage with latest versions of Django - add support for python -m gunicorn - fix systemd socket activation example - allows to set wsgi application in configg file using wsgi_app - document --timeout = 0 - always close a connection when the number of requests exceeds the max requests - Disable keepalive during graceful shutdown - kill tasks in the gthread workers during upgrade - fix latency in gevent worker when accepting new requests - fix file watcher: handle errors when new worker reboot and ensure the list of files is kept - document the default name and path of the configuration file - document how variable impact configuration - document the $PORT environment variable - added milliseconds option to request_time in access_log - added PIP requirements to be used for example - remove version from the Server header - fix sendfile: use socket.sendfile instead of os.sendfile - reloader: use absolute path to prevent empty to prevent0 InotifyError when a file is added to the working directory - Add --print-config option to print the resolved settings at startup. - remove the --log-dict-config CLI flag because it never had a working format (the logconfig_dict setting in configuration files continues to work) Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb b/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
new file mode 100644
index 0000000000..22fe495f42
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gunicorn_20.1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "WSGI HTTP Server for UNIX"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f75f3fb94cdeab1d607e2adaa6077752"
+
+SRC_URI[sha256sum] = "e0a968b5ba15f8a328fdfd7ab1fcb5af4470c28aaf7e55df02a99bc13138e6e8"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN} += "${PYTHON_PN}-setuptools ${PYTHON_PN}-fcntl"