aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-06-24 10:07:26 +0800
committerKhem Raj <raj.khem@gmail.com>2021-06-28 09:02:47 -0700
commit7d75d6f6f05e3cf16e2b01eb91dac3858ce47b40 (patch)
tree81d096e348d59e489d0cb314500309f9402797a4 /meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb
parent63d094d8f2325997d457bbcf92325f597b0a8c6c (diff)
downloadmeta-openembedded-contrib-7d75d6f6f05e3cf16e2b01eb91dac3858ce47b40.tar.gz
python3-grpcio-tools: upgrade 1.37.0 -> 1.38.1
Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb
new file mode 100644
index 0000000000..e6680e84b9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.38.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Google gRPC tools"
+HOMEPAGE = "http://www.grpc.io/"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-grpcio"
+
+SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
+
+SRC_URI[sha256sum] = "cd85f58038b92e1961f8127d79691e84e151390d35cae73c4c0cbe2042f76b77"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-grpcio"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# Needs abseil-cpp which does not build for ppc64le/musl
+COMPATIBLE_HOST_libc-musl_powerpc64le = "null"
+