aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-graphviz_0.16.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-02-03 17:38:20 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-05 10:26:11 -0800
commit8ebc0ab3eb02e45e36b5309f2210276ae1cef0ed (patch)
tree9c1c9f01a0419d43b87daaa99b33207bdaa301ae /meta-python/recipes-devtools/python/python3-graphviz_0.16.bb
parent53bc6fabbd23504f650c571ecc016727c40f2fcd (diff)
downloadmeta-openembedded-contrib-8ebc0ab3eb02e45e36b5309f2210276ae1cef0ed.tar.gz
python3-graphviz: Upgrade 0.14.2 -> 0.16
Upgrade to release 0.16: - Add ``.unflatten()`` method to ``Graph``, ``Digraph``, and ``Source``. Add standalone ``unflatten()``. - Make ``Source.__str__()`` return the ``.source`` instead of the ``repr()`` (like ``Graph`` and ``Digraph``). - Render with ``dot -K<engine> ...`` instead of ``<engine> ...`` internally. - Add documentation hint to archived upstream version for Windows. - Re-render most documentation graphs with Graphviz 2.44.1. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-graphviz_0.16.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-graphviz_0.16.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-graphviz_0.16.bb b/meta-python/recipes-devtools/python/python3-graphviz_0.16.bb
new file mode 100644
index 0000000000..1af657098b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-graphviz_0.16.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Graphviz protocol implementation"
+HOMEPAGE = "https://graphviz.readthedocs.io/en/stable/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f7831c564aeff14e68aa4ff7a93dc89f"
+
+SRC_URI[sha256sum] = "d2d25af1c199cad567ce4806f0449cb74eb30cf451fd7597251e1da099ac6e57"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"