aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-11 12:15:27 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commit89312caa4b3cc6ccae89d08bad27f5717a7585ff (patch)
tree1e6f573889bde7dbc452fb197810bf837442255d /meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb
parentb21cad88671af10c20537649424068c3ce808b9e (diff)
downloadmeta-openembedded-contrib-89312caa4b3cc6ccae89d08bad27f5717a7585ff.tar.gz
python3-google-auth: Upgrade 1.32.0 -> 1.34.0
Upgrade to release 1.34.0: - support refresh callable on google.oauth2.credentials.Credentials - do not use the GAE APIs on gen2+ runtimes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb b/meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb
new file mode 100644
index 0000000000..92ad24800f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth_1.34.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Google Authentication Library"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
+AUTHOR = "Google Cloud Platform"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "f1094088bae046fb06f3d1a3d7df14717e8d959e9105b79c57725bd4e17597a2"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-aiohttp \
+ ${PYTHON_PN}-cachetools \
+ ${PYTHON_PN}-pyasn1-modules \
+ ${PYTHON_PN}-rsa \
+ ${PYTHON_PN}-six \
+"