aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-11 12:15:28 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commit66d636c27ca1d8bd947f2a0f730bc4e9f60420bb (patch)
treeb178073ceac50b375c0e7e0a7bf8603e5b273552 /meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
parent89312caa4b3cc6ccae89d08bad27f5717a7585ff (diff)
downloadmeta-openembedded-contrib-66d636c27ca1d8bd947f2a0f730bc4e9f60420bb.tar.gz
python3-google-api-python-client: Upgrade 2.12.0 -> 2.15.0
Upgrade to release 2.15.0: - alertcenter: update the api - chat: update the api - cloudbuild: update the api - content: update the api - displayvideo: update the api - dns: update the api - eventarc: update the api - file: update the api - monitoring: update the api - people: update the api - retail: update the api - securitycenter: update the api - speech: update the api - sqladmin: update the api License-Update: update license to be Apache-2.0 compliant Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
new file mode 100644
index 0000000000..6172cd28f5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.15.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
+Moderator, and many other Google APIs."
+HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "8375489232823f44c601196a960505e03ec58c95ddb6415c6b1d1d76b468f8ba"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-httplib2 \
+ ${PYTHON_PN}-uritemplate \
+ ${PYTHON_PN}-google-api-core \
+"