aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-13 05:24:53 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-13 09:38:08 -0700
commita19be0890100022853e3bef457a3132ce153f6af (patch)
tree55c6d8aaa9fbd475bf8388c4b19140c45c0b5303 /meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb
parent614b1fac222146f389c065cf21f6438381864504 (diff)
downloadmeta-openembedded-contrib-a19be0890100022853e3bef457a3132ce153f6af.tar.gz
python3-google-api-python-client: upgrade 2.10.0 -> 2.12.0
Features artifactregistry: update the api bc9a38b (a933dad) chat: update the api eea3c5c (a933dad) cloudasset: update the api 2e31dd0 (a933dad) cloudbuild: update the api 3a3b420 (a933dad) composer: update the api 78c0d8d (a933dad) container: update the api a54737f (a933dad) datafusion: update the api f6bf3c6 (a933dad) dataproc: update the api 3fde9a3 (a933dad) documentai: update the api 79c556d (a933dad) groupssettings: update the api d537f96 (a933dad) logging: update the api d3548c5 (a933dad) monitoring: update the api d24af68 (a933dad) paymentsresellersubscription: update the api cff9039 (a933dad) redis: update the api 46102d1 (a933dad) run: update the api db18e29 (a933dad) slides: update the api 68634cd (a933dad) spanner: update the api 2895121 (a933dad) storagetransfer: update the api 24895f1 (a933dad) Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb
new file mode 100644
index 0000000000..67d05b5dd0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-python-client_2.12.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "The Google API Client for Python is a client library for accessing the Plus, \
+Moderator, and many other Google APIs."
+HOMEPAGE = "https://github.com/googleapis/google-api-python-client"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94023d14f6b58272fd885e4e3f2f08b3"
+
+SRC_URI[sha256sum] = "a5d203241a93201a770c966f8eca39de7f88b28194f9d252065b18e83bd99c4b"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-httplib2 \
+ ${PYTHON_PN}-uritemplate \
+ ${PYTHON_PN}-google-api-core \
+"