aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-11 12:15:26 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commitb21cad88671af10c20537649424068c3ce808b9e (patch)
tree7405915f1063a8474d305a577ea85be22e1fa37e /meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb
parent5d6fc2c1a18b64986bb69965b0119006b20cfe65 (diff)
downloadmeta-openembedded-contrib-b21cad88671af10c20537649424068c3ce808b9e.tar.gz
python3-google-api-core: Upgrade 1.30.0 -> 1.31.1
Upgrade to release 1.31.1: - add 'requests.exceptions.ChunkedEncodingError' to retryable exceptions - add Samples section to CONTRIBUTING.rst - add ServiceUnavailable exception to polling retries - undprecate entity factory helpers Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb b/meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb
new file mode 100644
index 0000000000..fe0aebb527
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_1.31.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Google API client core library"
+HOMEPAGE = "https://github.com/googleapis/python-api-core"
+AUTHOR = "Google LLC"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "108cf94336aed7e614eafc53933ef02adf63b9f0fd87e8f8212acaa09eaca456"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-googleapis-common-protos \
+ ${PYTHON_PN}-google-auth \
+ ${PYTHON_PN}-grpcio \
+ ${PYTHON_PN}-protobuf \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-six \
+"