aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-15 05:34:50 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-16 08:57:37 -0700
commite1b1a13c4b291e2df6a346d0f44a889e249ef33e (patch)
treea2dbd2ee225efc95e20b99eead353e3fad9d2902 /meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb
parent8f4ef229d8157f310478bb435be96aa338eee8d3 (diff)
downloadmeta-openembedded-contrib-e1b1a13c4b291e2df6a346d0f44a889e249ef33e.tar.gz
python3-gnupg: upgrade 0.4.6 -> 0.4.7
Released: 2021-03-11 Fixed #129, #141: Added support for no passphrase during key generation. Fixed #143: Improved permission-denied test. Thanks to Elliot Cameron for the patch. Fixed #144: Updated logging to only show partial results. Fixed #146: Allowed a passphrase to be passed to import_keys(). Thanks to Chris de Graaf for the patch. Add runtime dependency to resolve errors that occurred when import gnupg. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb b/meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb
new file mode 100644
index 0000000000..cc441af0b8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gnupg_0.4.7.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A wrapper for the Gnu Privacy Guard (GPG or GnuPG)"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b0b7ac63b60085b23fa9f7e1951daa1d"
+
+PYPI_PACKAGE = "python-gnupg"
+SRC_URI[sha256sum] = "2061f56b1942c29b92727bf9aecbd3cea3893acc9cccbdc7eb4604285efe4ac7"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ gnupg-gpg \
+ python3-logging \
+"