aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask_2.0.2.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-10-22 05:10:12 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-25 08:35:04 -0700
commitf7047afdb0207b7778a594e4b56b8fc75aa2416a (patch)
treee0b696e7682cef27de8597708c7e97a6eb631982 /meta-python/recipes-devtools/python/python3-flask_2.0.2.bb
parent0e41e90e87f3134c93d5425ec609a47024417df9 (diff)
downloadmeta-openembedded-contrib-f7047afdb0207b7778a594e4b56b8fc75aa2416a.tar.gz
python3-flask: upgrade 2.0.1 -> 2.0.2
Version 2.0.2 ------------- Released 2021-10-04 - Fix type annotation for ``teardown_*`` methods. :issue:`4093` - Fix type annotation for ``before_request`` and ``before_app_request`` decorators. :issue:`4104` - Fixed the issue where typing requires template global decorators to accept functions with no arguments. :issue:`4098` - Support View and MethodView instances with async handlers. :issue:`4112` - Enhance typing of ``app.errorhandler`` decorator. :issue:`4095` - Fix registering a blueprint twice with differing names. :issue:`4124` - Fix the type of ``static_folder`` to accept ``pathlib.Path``. :issue:`4150` - ``jsonify`` handles ``decimal.Decimal`` by encoding to ``str``. :issue:`4157` - Correctly handle raising deferred errors in CLI lazy loading. :issue:`4096` - The CLI loader handles ``**kwargs`` in a ``create_app`` function. :issue:`4170` - Fix the order of ``before_request`` and other callbacks that trigger before the view returns. They are called from the app down to the closest nested blueprint. :issue:`4229` Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask_2.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_2.0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_2.0.2.bb b/meta-python/recipes-devtools/python/python3-flask_2.0.2.bb
new file mode 100644
index 0000000000..e3f1df3562
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask_2.0.2.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
+DESCRIPTION = "\
+Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
+intentions. And before you ask: It’s BSD licensed!"
+HOMEPAGE = "https://github.com/mitsuhiko/flask/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
+
+SRC_URI[sha256sum] = "7b2fb8e934ddd50731893bdcdb00fc8c0315916f9fcd50d22c7cc1a95ab634e2"
+
+PYPI_PACKAGE = "Flask"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS:${PN} = " \
+ ${PYTHON_PN}-werkzeug \
+ ${PYTHON_PN}-jinja2 \
+ ${PYTHON_PN}-itsdangerous \
+ ${PYTHON_PN}-click \
+ ${PYTHON_PN}-profile \
+"