aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-27 17:55:02 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:27:23 -0700
commit0118db5ab6b119de109be9baaaaa9d58db059d59 (patch)
tree044d272f3a8182e626b7a4cca74da38bb5f5c643 /meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb
parentd63f4faa5a6e048b195e6a0b963786e82da9c6e0 (diff)
downloadmeta-openembedded-contrib-0118db5ab6b119de109be9baaaaa9d58db059d59.tar.gz
python3-flask-restful: Upgrade 0.3.7 -> 0.3.8
Upgrade to release 0.3.8: - Add Python 3.8 support - Fix wrongly parsed Decimal fields - Fix overridden response when calling abort with Response - Various small fixes and updates to documentation Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb
new file mode 100644
index 0000000000..3de916afd7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-restful_0.3.8.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Simple framework for creating REST APIs"
+DESCRIPTION = "\
+Flask-RESTful is an extension for Flask that adds support for quickly building \
+REST APIs"
+HOMEPAGE = "https://github.com/flask-restful/flask-restful"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=685bb55ed99a366bb431995f5eef2783"
+
+SRC_URI[md5sum] = "e8051ff104ab4b3b867ba18d28953fae"
+SRC_URI[sha256sum] = "5ea9a5991abf2cb69b4aac19793faac6c032300505b325687d7c305ffaa76915"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "Flask-RESTful"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-flask"