aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-27 17:54:58 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:27:05 -0700
commitec486ac8437dd8c68bc0aaa9c76c270a3d9cd0fd (patch)
tree3f16f9bb18f649db191abe5fa4836287ed760519 /meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb
parent0f3a77cd0cd7555baa91ebd5b6c97491e1eec74e (diff)
downloadmeta-openembedded-contrib-ec486ac8437dd8c68bc0aaa9c76c270a3d9cd0fd.tar.gz
python3-flask-babel: Upgrade 1.0.0 -> 2.0.0
Upgrade to release 2.0.0: - Drop Python2 support - Tests moved from unittest to pytest - Domain and caching support from Flask-BabelEx - Documentation moved from python-hosted to Github Pages. - CI moved from Travisci to Github Actions - Small documentation improvements. - Removed uncessary checks on get_translations() - localeselector and timezoneselector can be changed after creation. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb b/meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb
new file mode 100644
index 0000000000..8a01b49b45
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-babel_2.0.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "i18n and l10n support for Flask based on babel and pytz"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51917f3e8e858f5ae295a7d0e2eb3cc9"
+
+SRC_URI[md5sum] = "50d5e92d96ef58787bf85b5a1b0a5567"
+SRC_URI[sha256sum] = "f9faf45cdb2e1a32ea2ec14403587d4295108f35017a7821a2b1acb8cfd9257d"
+
+PYPI_PACKAGE = "Flask-Babel"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-speaklater \
+ ${PYTHON_PN}-babel \
+ ${PYTHON_PN}-flask \
+ "