aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 15:59:30 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-23 10:45:31 -0700
commitb32b4347244b043f442b860550c21f78f34f5e5c (patch)
tree5f465d4cb7340c45f5d808884c75dc73908b41f9 /meta-python/recipes-devtools/python/python3-fields_5.0.0.bb
parentfa2d3338fb87a38a66d11735b876ce2320045b0d (diff)
downloadmeta-openembedded-contrib-b32b4347244b043f442b860550c21f78f34f5e5c.tar.gz
meta-python: Add python3-fastjsonschema and its dependencies
python3-fastjsonschema claims to be fastest Python implementation of JSON schema it however needs additional packages which are also added here, since they are all dependent, its added in single commit so backporting is simpler Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-fields_5.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-fields_5.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb b/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb
new file mode 100644
index 0000000000..9c22b920d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-fields_5.0.0.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Container class boilerplate killer."
+HOMEPAGE = "https://github.com/ionelmc/python-fields"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e32c6705498713d9c904a9f565953a2c"
+
+SRC_URI[sha256sum] = "31d4aa03d8d44e35df13c431de35136997f047a924a597d84f7bc209e1be5727"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-core"
+
+BBCLASSEXTEND = "native nativesdk"