aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-03 16:42:32 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-05 18:43:10 -0700
commitc13b51f12b25e49354c16302ceb7aaeb2bb8f8a7 (patch)
treec9c320a1c6c9015aa453ab1be820b94d722b5826 /meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
parent870a2f8e541f9c525f1cb4e3b90ed24658c0a1e2 (diff)
downloadmeta-openembedded-contrib-c13b51f12b25e49354c16302ceb7aaeb2bb8f8a7.tar.gz
python3-feedformatter: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
index 95a5405f38..81c5fde132 100644
--- a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
@@ -1,2 +1,18 @@
+DESCRIPTION = "A Python library for generating news feeds in RSS and Atom formats"
+HOMEPAGE = "http://code.google.com/p/feedformatter/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d"
+
+SRC_URI = "git://github.com/marianoguerra/feedformatter.git"
+SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85"
+
+S = "${WORKDIR}/git"
+
inherit setuptools3
-require python-feedformatter.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-xml \
+ "