aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-21 14:16:04 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-22 22:17:04 -0700
commit4eb7dff81cfeac4b886401be512d8a55397d3ca3 (patch)
tree6d18495faa04e01c8ee9afad240bed2a71f4795b /meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb
parent4fbb740722d37a9665c516dfca2e6c60174df24d (diff)
downloadmeta-openembedded-contrib-4eb7dff81cfeac4b886401be512d8a55397d3ca3.tar.gz
python3-dominate: Upgrade 2.5.2 -> 2.6.0
Upgrade to release 2.6.0: - Add get_current() to return the current active element in a with context Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb b/meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb
new file mode 100644
index 0000000000..b7c738d656
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.6.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API."
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
+
+SRC_URI[md5sum] = "9f714324ca99eee98bb3c3cdbe838de6"
+SRC_URI[sha256sum] = "76ec2cde23700a6fc4fee098168b9dee43b99c2f1dd0ca6a711f683e8eb7e1e4"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+ "