aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-django_3.2.5.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-07-14 08:54:16 -0400
committerKhem Raj <raj.khem@gmail.com>2021-07-16 08:57:37 -0700
commitfe50bd100548500842667210df9757d84ec11b16 (patch)
treea12a8407d5f2eded9e2aec6eb1e6b4f56bdac513 /meta-python/recipes-devtools/python/python3-django_3.2.5.bb
parente4202c91241457b6c9bc4c948ced5315f79337f7 (diff)
downloadmeta-openembedded-contrib-fe50bd100548500842667210df9757d84ec11b16.tar.gz
python3-django: upgrade 3.2.4 -> 3.2.5
3.2.5 fixes CVE-2021-35042: Potential SQL injection via unsanitized QuerySet.order_by() input. Additional release notes: - Fixed a regression in Django 3.2 that caused a crash of QuerySet.values_list(…, named=True) after prefetch_related() (#32812). - Fixed a bug in Django 3.2 that caused a migration crash on MySQL 8.0.13+ when altering BinaryField, JSONField, or TextField to non-nullable (#32503). - Fixed a regression in Django 3.2 that caused a migration crash on MySQL 8.0.13+ when adding nullable BinaryField, JSONField, or TextField with a default value (#32832). - Fixed a bug in Django 3.2 where a system check would crash on a model with an invalid app_label (#32863). There is no corresponding uprev for the 2.x LTS branch since it is already at the latest version (2.2.24). Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-django_3.2.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-django_3.2.5.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_3.2.5.bb b/meta-python/recipes-devtools/python/python3-django_3.2.5.bb
new file mode 100644
index 0000000000..5890c85419
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-django_3.2.5.bb
@@ -0,0 +1,13 @@
+require python-django.inc
+inherit setuptools3
+
+SRC_URI[sha256sum] = "3da05fea54fdec2315b54a563d5b59f3b4e2b1e69c3a5841dda35019c01855cd"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-sqlparse \
+"
+
+# Set DEFAULT_PREFERENCE so that the LTS version of django is built by
+# default. To build the 3.x branch,
+# PREFERRED_VERSION_python3-django = "3.2.2" can be added to local.conf
+DEFAULT_PREFERENCE = "-1"