aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-10 11:30:58 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commit82c9ddd853c44b1f2e349657f32e6b8555a77704 (patch)
tree0bbcf0d344049cccf8c7b00f4fed97e5d8c59e39 /meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
parentc40c069a73c40a99688ad04abebe10e8e4efc603 (diff)
downloadmeta-openembedded-contrib-82c9ddd853c44b1f2e349657f32e6b8555a77704.tar.gz
python3-distro: Upgrade 1.5.0 -> 1.6.0
Upgrade to release: BACKWARDS COMPATIBILITY: - Deprecated the distro.linux_distribution() function. Use distro.id(), distro.version() and distro.name() instead - Deprecated Python 2.7, 3.4 and 3.5 support. Further releases will only support Python 3.6+ ENHANCEMENTS: - Added type hints to distro module - Added __version__ for checking distro version - Added support for arbitrary rootfs via the root_dir parameter - Added the --root-dir option to CLI - Added fallback to /usr/lib/os-release when /etc/os-release isn't available BUG FIXES: - Fixed subprocess.CalledProcessError when running lsb_release - Ignore /etc/iredmail-release file while parsing distribution - Use a binary file for /dev/null to avoid TextIOWrapper overhead RELEASE: - Moved repository from nir0s/distro to python-distro/distro on GitHub. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-distro_1.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-distro_1.6.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
new file mode 100644
index 0000000000..8aa2255670
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-distro_1.6.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Distro is an OS platform information API"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+PYPI_PACKAGE = "distro"
+
+SRC_URI[sha256sum] = "83f5e5a09f9c5f68f60173de572930effbcc0287bb84fdc4426cb4168c088424"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"