aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-14 12:04:14 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-15 09:28:34 -0700
commit35e3e374d676908c5b7aaeda2696b1bcfbbc9522 (patch)
treec4cf3ed3f9f40d6289b4da41085d053afc5a5f4f /meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb
parent3cb8969680520c3e1242c5c2d71da573dbd0548f (diff)
downloadmeta-openembedded-contrib-35e3e374d676908c5b7aaeda2696b1bcfbbc9522.tar.gz
python3-dbus-next: Upgrade 0.1.3 -> 0.1.4
Upgrade to release 0.1.4: - Support tcp transport addresses - Add support for the annonymous authentication protocol - Add flags kwarg to aio high level client method call - Allow subclassing of DBusError - Fix exception in aio message handler loop on task cancellation - Improve error messages - Fix match rule memory leak bug - Don't add match rules for high level client by default - Add empty properties interface to standard interfaces Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb b/meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb
new file mode 100644
index 0000000000..0a5f19974a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbus-next_0.1.4.bb
@@ -0,0 +1,13 @@
+SUMMARY = "A zero-dependency DBus library for Python with asyncio support"
+HOMEPAGE = "https://github.com/acrisci/python-dbus-next"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=94e750c96e56788499b56c81de91431c"
+
+SRC_URI[md5sum] = "0d44e12e8689637a0c048ec7bb51d842"
+SRC_URI[sha256sum] = "1b1942bffcc8c9a5bd6834257df227a55ee28e07dd413ead82ddd23115652363"
+
+PYPI_PACKAGE = "dbus_next"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"