aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-05 14:11:23 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-05 11:02:04 -0800
commitf1a49372b3ab84bab57fe6b550ac8694bcbf7a50 (patch)
tree533001bbf17c9473d69d064c5162f105f397b580 /meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
parent39e13efc0847bafdb1f176a5c2e0970170e683b0 (diff)
downloadmeta-openembedded-contrib-f1a49372b3ab84bab57fe6b550ac8694bcbf7a50.tar.gz
python3-dateutil: upgrade 2.8.2 -> 2.9.0
Changelog: Data updates Updated tzdata version to 2024a. Features Made all dateutil submodules lazily imported using PEP 562. On Python 3.7+, things like import dateutil; dateutil.tz.gettz("America/New_York") will now work without explicitly importing dateutil. tz, with the import occurring behind the scenes on first use. The old behavior remains on Python 3.6 and earlier. Bugfixes Removed a call to datetime.utcfromtimestamp, which is deprecated as of Python 3.12. Documentation changes Added note into docs and tests where relativedelta would return last day of the month only if the same day on a different month resolves to a date that doesn't exist. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
new file mode 100644
index 0000000000..bcb68d7714
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.9.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Extensions to the standard Python datetime module"
+DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library."
+HOMEPAGE = "https://dateutil.readthedocs.org"
+LICENSE = "BSD-3-Clause & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
+
+SRC_URI[sha256sum] = "78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709"
+
+PYPI_PACKAGE = "python-dateutil"
+PIP_INSTALL_PACKAGE = "python_dateutil"
+inherit pypi python_setuptools_build_meta
+
+PACKAGES =+ "${PN}-zoneinfo"
+FILES:${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} = "\
+ python3-datetime \
+ python3-numbers \
+ python3-six \
+ python3-stringold \
+"
+
+BBCLASSEXTEND = "native nativesdk"