aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-07-15 19:09:06 +0300
committerKhem Raj <raj.khem@gmail.com>2021-07-16 08:57:37 -0700
commit7f9fcfab67de6729ac47bfb826c55c7ae1721dce (patch)
tree5308866147593f9feee8969c22f80ad146b2ea25 /meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
parent9e005453c6e99ddbdf372a8c9880d7ca432f03b0 (diff)
downloadmeta-openembedded-contrib-7f9fcfab67de6729ac47bfb826c55c7ae1721dce.tar.gz
python3-dateutil: Upgrade 2.8.1 -> 2.8.2
Upgrade to release 2.8.2: - Updated tzdata version to 2021a - Fixed a bug in the parser where non-ValueError exceptions would be raised during exception handling; this would happen, for example, if an IllegalMonthError was raised in dateutil code. - Fixed the custom repr for dateutil.parser.ParserError, which was not defined due to an indentation error. - Fixed a bug that caused b' prefixes to appear in parse_isodate exception messages. - Make isoparse raise when trying to parse times with inconsistent use of : separator. - Fixed tz.gettz() not returning local time when passed an empty string. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb b/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
new file mode 100644
index 0000000000..a68a736a8c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dateutil_2.8.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Extensions to the standard Python datetime module"
+DESCRIPTION = "The dateutil module provides powerful extensions to the datetime module available in the Python standard library."
+HOMEPAGE = "https://dateutil.readthedocs.org"
+LICENSE = "BSD-3-Clause & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
+
+SRC_URI[sha256sum] = "0123cacc1627ae19ddf3c27a5de5bd67ee4586fbdd6440d9748f8abb483d3e86"
+
+PYPI_PACKAGE = "python-dateutil"
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-zoneinfo"
+FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native nativesdk"