aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cython_0.29.12.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-07-11 16:15:04 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-11 14:01:28 -0700
commit8bc18c5d45b781fb1f37c3574a0b2a02f048ef1a (patch)
treec4c22ee0b7c6aa6199c1f9a3a5719ce3d141e4b3 /meta-python/recipes-devtools/python/python3-cython_0.29.12.bb
parent44d7521fbf40d59173278abf47e3e27a2f15a265 (diff)
downloadmeta-openembedded-contrib-8bc18c5d45b781fb1f37c3574a0b2a02f048ef1a.tar.gz
python-cython: upgrade 0.29.11 -> 0.29.12
-Upgrade from python-cython_0.29.11.bb to python-cython_0.29.12.bb. -Upgrade from python3-cython_0.29.11.bb to python3-cython_0.29.12.bb. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cython_0.29.12.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cython_0.29.12.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cython_0.29.12.bb b/meta-python/recipes-devtools/python/python3-cython_0.29.12.bb
new file mode 100644
index 0000000000..2ce6bdbd68
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cython_0.29.12.bb
@@ -0,0 +1,18 @@
+inherit setuptools3
+require python-cython.inc
+
+RDEPENDS_${PN} += "\
+ python3-setuptools \
+"
+
+# running build_ext a second time during install fails, because Python
+# would then attempt to import cythonized modules built for the target
+# architecture.
+DISTUTILS_INSTALL_ARGS += "--skip-build"
+
+do_install_append() {
+ # rename scripts that would conflict with the Python 2 build of Cython
+ mv ${D}${bindir}/cython ${D}${bindir}/cython3
+ mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3
+ mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3
+}