aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:11:48 -0700
committerTim Orling <ticotimo@gmail.com>2021-08-24 10:11:23 -0700
commit858bcac5be7c9638be8ce7e8cffe469575fa36a8 (patch)
treef5e746950d17f8a43ad320e226f5917d0a72cae2 /meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
parent88c67feaf1c3635ad954fcb55289c74227aee3bb (diff)
downloadmeta-openembedded-contrib-858bcac5be7c9638be8ce7e8cffe469575fa36a8.tar.gz
python3-cryptography: upgrade 3.3.2 -> 3.4.7timo/python3-cryptography_no_rust
RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the patch for skipping. Use the CRYPTOGRAPHY_DONT_BUILD_RUST=1 hammer for now, since rust support in oe-core is not ready yet. An alternative would be to move recipe to dynamic-layers and depend on meta-rust, which would also require python3-setuptools-rust in same dynamic layer. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
new file mode 100644
index 0000000000..8781c80870
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography_3.4.7.bb
@@ -0,0 +1,68 @@
+SUMMARY = "Provides cryptographic recipes and primitives to python developers"
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
+
+LDSHARED += "-pthread"
+
+SRC_URI[sha256sum] = "3d10de8116d25649631977cb37da6cbdd2d6fa0e0281d014a5b7d337255ca713"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+inherit pypi setuptools3
+
+# We don't have rust support in oe-core yet
+export CRYPTOGRAPHY_DONT_BUILD_RUST=1
+
+DEPENDS += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-cffi-native \
+ ${PYTHON_PN}-asn1crypto \
+ ${PYTHON_PN}-six \
+"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-asn1crypto \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+"
+
+RDEPENDS:${PN}:class-target += " \
+ ${PYTHON_PN}-cffi \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-asn1crypto \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-threading \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PN} \
+ ${PYTHON_PN}-cryptography-vectors \
+ ${PYTHON_PN}-hypothesis \
+ ${PYTHON_PN}-iso8601 \
+ ${PYTHON_PN}-pretend \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-pytz \
+"
+
+inherit ptest
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests/hazmat
+ cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
+}
+
+FILES:${PN}-dbg += " \
+ ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
+"
+
+BBCLASSEXTEND = "native nativesdk"