aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-01-15 10:48:49 -0800
committerTim Orling <tim.orling@konsulko.com>2022-01-16 08:58:36 -0800
commitccbbadc9e32ee3051b7a086d578e9f322484671e (patch)
tree92ea3e0dab44d30eff169b7ab428a1b6b6717ed7 /meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
parent145baad01bbe2c3240b535cffd554815cf2e321b (diff)
downloadmeta-openembedded-contrib-ccbbadc9e32ee3051b7a086d578e9f322484671e.tar.gz
python3-cryptography-vectors: upgrade 35.0.0 => 36.0.1
Add note to remind contributors to keep this recipe in lock-step with python3-cryptography. They must be at the same version. 5bd0c10d allow parsing of nonstandard country name and jurisdiction country name (#6641) 78c2dd8a add AES SIV vectors (#6608) c451c1df add AES OCB3 test vectors (#6606) 4da2a681 Allow parsing CSR extensions with the critical bit having an explicitly encoded default (#6600) bb05d4b5 allow multiple identical pem blocks (#6551) f4871a21 add accvraiz1 bmpstring test vector (#6503) 667e7a5f Add new PKCS12 test vectors (#6383) 703de3af Accept combined PEM files with multiple sections (#6365) 51221b2c support legacy PEM headers for certificate and CSR (#6356) Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb b/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
new file mode 100644
index 0000000000..b9e6b811c3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Test vectors for the cryptography package."
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
+ file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
+ file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
+
+# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
+# Upgrade both recipes at the same time
+
+SRC_URI[sha256sum] = "fc8490afd5424342b868215435bd174dcd76ab396b4ea9435498be5721dcd598"
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-cryptography \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = ""