aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_5.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-29 12:20:20 +0300
committerKhem Raj <raj.khem@gmail.com>2021-03-30 09:04:35 -0700
commit496d23539dcd675655c040fa7957fb542b27c38e (patch)
tree4d9f3f28783f1a7160815150341d84720084f7fd /meta-python/recipes-devtools/python/python3-coverage_5.5.bb
parentb3b9798b76e63a400b477c6c1e6267a5337af00b (diff)
downloadmeta-openembedded-contrib-496d23539dcd675655c040fa7957fb542b27c38e.tar.gz
python3-coverage: Upgrade 5.4 -> 5.5
Upgrade to release 5.5: - coverage combine has a new option, --keep to keep the original data files after combining them. The default is still to delete the files after they have been combined. - When reporting missing branches in coverage report, branches aren't reported that jump to missing lines. This adds to the long-standing behavior of not reporting branches from missing lines. Now branches are only reported if both the source and destination lines are executed. - Minor improvements to the HTML report: The state of the line visibility selector buttons is saved in local storage so you don't have to fiddle with them so often. It has a little more room for line numbers so that 4-digit numbers work well. - Improved the error message when combining line and branch data, so that users will be more likely to understand what's happening. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_5.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_5.5.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_5.5.bb b/meta-python/recipes-devtools/python/python3-coverage_5.5.bb
new file mode 100644
index 0000000000..c780a63ae9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_5.5.bb
@@ -0,0 +1,9 @@
+SUMMARY = "Code coverage measurement for Python"
+HOMEPAGE = "https://coverage.readthedocs.io"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[sha256sum] = "ebe78fe9a0e874362175b02371bdfbee64d8edc42a044253ddf4ee7d3c15212c"
+
+inherit pypi setuptools3
+