aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-coverage_5.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-22 13:49:05 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-23 10:27:10 -0700
commit76b83194b31ca57790fdffb43c81c8cb0131f527 (patch)
tree7c15e746c90fbd0a1aa79b6c29cfe21b0f43659f /meta-python/recipes-devtools/python/python3-coverage_5.2.bb
parent117af0bc9d01e9c79b1ca25a4dec0b04421ae922 (diff)
downloadmeta-openembedded-contrib-76b83194b31ca57790fdffb43c81c8cb0131f527.tar.gz
python3-coverage: Upgrade 5.1 -> 5.2
Upgrade to release 5.2: - The HTML report has been redesigned by Vince Salvino. There is now a dark mode, the code text is larger, and system sans serif fonts are used, in addition to other small changes. - The coverage report and coverage html commands now accept a --precision option to control the number of decimal points displayed. Thanks, Teake Nutma. - The coverage report and coverage html commands now accept a --no-skip-covered option to negate --skip-covered. Thanks, Anthony Sottile. - The --skip-empty option is now available for the XML report. - The coverage report command now accepts a --sort option to specify how to sort the results. Thanks, Jerin Peter George. - If coverage fails due to the coverage total not reaching the --fail-under value, it will now print a message making the condition clear. Thanks, Naveen Yadav. - TOML configuration files with non-ASCII characters would cause errors on Windows. This is now fixed. - The output of --debug=trace now includes information about how the --source option is being interpreted, and the module names being considered. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-coverage_5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-coverage_5.2.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-coverage_5.2.bb b/meta-python/recipes-devtools/python/python3-coverage_5.2.bb
new file mode 100644
index 0000000000..72558e10c4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-coverage_5.2.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Code coverage measurement for Python"
+HOMEPAGE = "https://coverage.readthedocs.io"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[md5sum] = "bfe80a336636160a3916467f55842bc5"
+SRC_URI[sha256sum] = "1874bdc943654ba46d28f179c1846f5710eda3aeb265ff029e0ac2b52daae404"
+
+inherit pypi setuptools3
+