aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-12-22 03:14:58 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-04 14:48:29 -0800
commit8d838b084476a92f6b64ef12ab680f5614ecd263 (patch)
treedbdab796213ee99140773ec5e7b4445b0811892b /meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb
parent69bae2a2360643805de2ae1cd9ebc4202cd5a2fb (diff)
downloadmeta-openembedded-contrib-8d838b084476a92f6b64ef12ab680f5614ecd263.tar.gz
python3-chardet: Upgrade 3.0.4 -> 4.0.0
Upgrade to release 4.0.0: - Single-byte charset probers now use nested dictionaries under the hood, so they are usually a little faster than before. - The CharsetGroupProber class now properly short-circuits when one of the probers in the group is considered a definite match. This lead to a substantial speedup. - There is now a chardet.detect_all function that returns a list of possible encodings for the input with associated confidences. - Support for Python 2.6, 3.4, and 3.5 was dropped as they are all past end-of-life. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb b/meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb
new file mode 100644
index 0000000000..4caf33cb25
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-chardet_4.0.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Universal encoding detector for Python 2 and 3"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+SRC_URI[sha256sum] = "0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa"
+
+# setup.py of chardet needs this.
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-cli"
+FILES_${PN}-cli += " \
+ ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
+"
+
+RDEPENDS_${PN}-cli = "${PN} "
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"