aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:48:02 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitc3d10cd377406fa3ce7286965bfe64c1b1c67a90 (patch)
tree5747dc4d7839c2133e1668a45e9b1aa9e9b24e5d /meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
parent1dbe0e298140bd549345f6a21371dea507d36434 (diff)
downloadmeta-openembedded-contrib-c3d10cd377406fa3ce7286965bfe64c1b1c67a90.tar.gz
python3-chardet: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb29
1 files changed, 23 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
index 38d8122ce9..80785b8d4e 100644
--- a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
@@ -1,7 +1,24 @@
-inherit setuptools3
-require python-chardet.inc
+SUMMARY = "Universal encoding detector for Python 2 and 3"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
-do_install_append () {
- # rename scripts that would conflict with the Python 2 build of chardet
- mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect3
-}
+SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c"
+SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae"
+
+# setup.py of chardet needs this.
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-cli"
+FILES_${PN}-cli += " \
+ ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
+"
+
+RDEPENDS_${PN}-cli = "${PN} "
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"