aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-15 12:02:54 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-16 09:14:22 -0700
commitb31347847d4165baaa75d30b9648cf22d1b4b378 (patch)
tree5ee31238417d75155c221fcf980006669081615a /meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb
parent7a0edf425e4b930dd8e246269d1fbfefc300d907 (diff)
downloadmeta-openembedded-contrib-b31347847d4165baaa75d30b9648cf22d1b4b378.tar.gz
python3-cffi: Upgrade 1.14.2 -> 1.14.3
Upgrade to release 1.14.3: - Don't call PyEval_InitThreads() on CPython >= 3.7, where it should always be a no-op. It is explicitly deprecated in 3.9. - Let the test run directly on pypy too - Remove extremely old and outdated .gitignore Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb b/meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb
new file mode 100644
index 0000000000..dbdd16f66e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cffi_1.14.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Foreign Function Interface for Python calling C code"
+HOMEPAGE = "http://cffi.readthedocs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
+DEPENDS += "libffi ${PYTHON_PN}-pycparser"
+
+SRC_URI[md5sum] = "c2a47ffd5d183b193ac8ed3414dcfd07"
+SRC_URI[sha256sum] = "f92f789e4f9241cd262ad7a555ca2c648a98178a953af117ef7fad46aa1d5591"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target = " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pycparser \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"