aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-12 17:02:06 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-13 08:06:07 -0700
commit4d94ced1ec43e7c9c0f8a24a5d3a2e7a219a7286 (patch)
treed2de8121bb5dde52bc53a83fcc6ae2acfc821290 /meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
parentd46d6e58c26f596fba7cbd739fe8856f89306ab6 (diff)
downloadmeta-openembedded-contrib-4d94ced1ec43e7c9c0f8a24a5d3a2e7a219a7286.tar.gz
python3-cerberus: Upgrade 1.3.2 -> 1.3.3
Minor code refactoring of the recipe and upgrade to release 1.3.3: - Classes can be used as constraint for the type rule - The abstract base classes of the standard library's collections.abc module are available as named types for the type rule - Generic type aliases from the :mod:`typing` module can be used as constraints for the type rule, including parametrized ones a.k.a. compound types - Support for Python 3.5 is removed. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb b/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
new file mode 100644
index 0000000000..fa0bbb0aad
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Lightweight, extensible schema and data validation tool for Python dictionaries."
+HOMEPAGE = "http://docs.python-cerberus.org/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=48f8e9432d0dac5e0e7a18211a0bacdb"
+
+# The PyPI package uses a capital letter so we have to specify this explicitly
+PYPI_PACKAGE = "Cerberus"
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "eec10585c33044fb7c69650bc5b68018dac0443753337e2b07684ee0f3c83329"