aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-08-02 11:29:58 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:52:31 -0700
commitd8e67165c68a380464e641f5a8b12c545b3e259d (patch)
tree98e353a3bbf9976e6d3b10081f97ba4654f65f1b /meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb
parent7fea625db55f4f5828050237634861f75789e1da (diff)
downloadmeta-openembedded-contrib-d8e67165c68a380464e641f5a8b12c545b3e259d.tar.gz
python3-cbor2: upgrade 5.4.0 -> 5.4.1
Added new feature stringrefs, which makes repetitive dictionary structures more compact. Use with care since support for this is rare in other CBOR implementations. This release includes some bugfixes around decoding invalid data, which may improve security on decoding untrusted data. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb b/meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb
new file mode 100644
index 0000000000..ba015a8188
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cbor2_5.4.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
+DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI[sha256sum] = "a8bf432f6cb595f50aeb8fed2a4aa3b3f7caa7f135fb57e4378eaa39242feac9"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"