aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-01 11:20:03 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-04 20:22:59 -0700
commitaf323dc29aa5cf80c963782695bda68dafe72c94 (patch)
tree95bb67f144935b4d033c6a18a286e21f5d86603f /meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb
parenta7e065c0b4a18b7a9cb4670ee50fb1f5a51b320f (diff)
downloadmeta-openembedded-contrib-af323dc29aa5cf80c963782695bda68dafe72c94.tar.gz
python3-cbor2: Upgrade 5.1.2 -> 5.2.0
Upgrade to release 5.2.0: - Final version tested with Python 2.7 and 3.5 - README: Announce deprecation of Python 2.7, 3.5 - README: More detail and examples - Bugfix: Fix segfault on loading huge arrays with C-backend - Build system: Allow packagers to force C-backend building or disable using env var - Feature: :module:`cbor2.tool` Command line diagnostic tool - Feature: Ignore semantic tag used for file magic 55799 AKA "Self-Described CBOR" Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb b/meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb
new file mode 100644
index 0000000000..cc067c41a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cbor2_5.2.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "An implementation of RFC 7049 - Concise Binary Object Representation (CBOR)."
+DEPENDS +="${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI[sha256sum] = "a33aa2e5534fd74401ac95686886e655e3b2ce6383b3f958199b6e70a87c94bf"
+SRC_URI[md5sum] = "0940aa8bfd1a07f06a983bb6dc78f1ca"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"