aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 17:33:46 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commite2e028c216825aed94b65467ca950f84832e27ca (patch)
tree13f5496d7aef85f46a6a8c903dfc8e5a411da42c /meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb
parentd3fdee897e9871e142f12efe8862e3341c0174e9 (diff)
downloadmeta-openembedded-contrib-e2e028c216825aed94b65467ca950f84832e27ca.tar.gz
python3-cassandra-driver: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb35
1 files changed, 31 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb
index 34f149d3f5..768e557b94 100644
--- a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.14.0.bb
@@ -1,8 +1,35 @@
-inherit setuptools3
-require python-cassandra-driver.inc
+SUMMARY = "DataStax Python Driver for Apache Cassandra"
+DESCRIPTION = "A modern, feature-rich and highly-tunable Python client \
+library for Apache Cassandra (1.2+) and DataStax Enterprise (3.1+) using \
+exclusively Cassandra's binary protocol and Cassandra Query Language v3."
+HOMEPAGE = "https://github.com/datastax/python-driver"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+SRCNAME = "cassandra-driver"
-# Requires concurrent which is currently in -misc
-RDEPENDS_${PN} += " \
+SRC_URI[md5sum] = "c5bed026bf48c821424c1f6296193908"
+SRC_URI[sha256sum] = "b65218e2582277f5b77d1436e420db8616f63e3437a9e839cdcd7172d760e861"
+
+DISTUTILS_BUILD_ARGS += " \
+ --no-libev \
+"
+DISTUTILS_INSTALL_ARGS += " \
+ --no-libev \
+"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-cython \
+ ${PYTHON_PN}-json \
${PYTHON_PN}-misc \
+ ${PYTHON_PN}-multiprocessing \
${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-six \
+ libevent \
+"
+
+DEPENDS += "\
+ ${PYTHON_PN}-cython \
"