aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-15 13:30:17 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:57:24 -0700
commit37616b499381e8a96309425fd92ba938b7cf3ee3 (patch)
tree0be6a1cb6e8f35746767aba1194bcd180d549b94 /meta-python/recipes-devtools/python/python3-can_3.3.3.bb
parent14c95befb3639cefafefa7b686b30c833773defb (diff)
downloadmeta-openembedded-contrib-37616b499381e8a96309425fd92ba938b7cf3ee3.tar.gz
python3-can: Upgrade 3.3.2 -> 3.3.3
Upgrade to release 3.3.3. It contains backported fixes from 4.x development branch which targets Python 3: - Backport caching msg.data value in neovi interface. - Fix Vector CANlib treatment of empty app name. - Handle empty CSV file. - ASCII reader can now handle FD frames. - Exclude test packages from distribution. - RTR crash fix in canutils log reader parsing RTR frames. - Skip J1939 messages in ASC Reader. - Exposes a configuration option to allow the CAN message player to send error frames (and sets the default to not send error frames). - Fixes the semantics provided by periodic tasks in SocketCAN interface. - Avoid padding CAN_FD_MESSAGE_64 objects to 4 bytes. - Fixes the broken CANalyst-II interface. - Socketcan BCM status fix. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-can_3.3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-can_3.3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-can_3.3.3.bb b/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
new file mode 100644
index 0000000000..4da2339598
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-can_3.3.3.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Controller Area Network (CAN) interface module for Python"
+SECTION = "devel/python"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI[md5sum] = "1310da316799e4b12944a6c1dcb017a9"
+SRC_URI[sha256sum] = "ecd69cf6b2f0235345ebe607a15325cf1384c85b24ffbe1d68c3754357f87488"
+
+PYPI_PACKAGE="python-can"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-aenum \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-sqlite3 \
+ ${PYTHON_PN}-wrapt \
+"
+
+BBCLASSEXTEND = "native nativesdk"