aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-28 16:54:47 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-29 08:43:53 -0700
commit0817913a638f27307a65a6d749309143e71a1c57 (patch)
tree60e21a551e079f9a0704290aa3b5b06394fddc78 /meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb
parent12c2e794c5a03b71673b857d42a9ae091816136d (diff)
downloadmeta-openembedded-contrib-0817913a638f27307a65a6d749309143e71a1c57.tar.gz
python3-cachetools: Upgrade 4.2.1 -> 4.2.2
Upgrade to release 4.2.2: - Update build environment. - Remove Python 2 remnants. - Format code with Black. License-Update: Fix copyright year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb
new file mode 100644
index 0000000000..43049dafe7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.2.2.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Extensible memoizing collections and decorators"
+HOMEPAGE = "https://github.com/tkem/cachetools"
+DESCRIPTION = "This module provides various memoizing \
+collections and decorators, including variants of the \
+Python 3 Standard Library @lru_cache function decorator."
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=439a07e400525964c3c82684146e46eb"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-math \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+SRC_URI[sha256sum] = "61b5ed1e22a0924aed1d23b478f37e8d52549ff8a961de2909c69bf950020cff"
+
+BBCLASSEXTEND = "native nativesdk"