aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:43 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commitb51dcf7d0452037ee4898f0a3de94c24fb61ab8e (patch)
tree6fea8dfdff06256cc93df833d0c4d8d3c4b0ad67 /meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
parentbe0e033b076c517b3d6e05db74ad751cb747db28 (diff)
downloadmeta-openembedded-contrib-b51dcf7d0452037ee4898f0a3de94c24fb61ab8e.tar.gz
python3-cachecontrol: add recipe for 0.12.6
This recipe originally comes from meta-openstack, but it's dependency-less, so it may as well live here and get wider use. meta-openstack is MIT-licensed, so the recipe is compatible. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
new file mode 100644
index 0000000000..7c45ed3300
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.12.6.bb
@@ -0,0 +1,29 @@
+SUMMARY = "httplib2 caching for requests"
+HOMEPAGE = "https://pypi.org/project/CacheControl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6dc7e1b428eda03d850209fdbd6c71f1"
+
+# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
+# override PYPI_PACKAGE so fetch succeeds.
+PYPI_PACKAGE = "CacheControl"
+
+SRC_URI[md5sum] = "5890b797f9b48b2b4cd1448cca89e396"
+SRC_URI[sha256sum] = "be9aa45477a134aee56c8fac518627e1154df063e85f67d4f83ce0ccc23688e8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-crypt \
+ python3-datetime \
+ python3-email \
+ python3-lockfile \
+ python3-json \
+ python3-logging \
+ python3-msgpack \
+ python3-netclient \
+ python3-pickle \
+ python3-requests \
+ python3-urllib3 \
+"
+
+BBCLASSEXTEND = "native nativesdk"