aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2020-07-03 11:54:51 -0400
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:21:18 -0700
commit8447ad3d2538ee1ebe90798f84abc52590e2926e (patch)
treebfb5823166fbd318eb2f165b115d4d61690dfd5e /meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb
parent5a118d5fede5eedce4302f74f0a334802534fee8 (diff)
downloadmeta-openembedded-contrib-8447ad3d2538ee1ebe90798f84abc52590e2926e.tar.gz
python3-betamax: add recipe
betamax is required for enabling ptest in python3-requests-toolbelt Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb b/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb
new file mode 100644
index 0000000000..ef654e9172
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-betamax_0.8.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "VCR imitation for python requests"
+HOMEPAGE = "https://github.com/betamaxpy/betamax"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+SRC_URI[md5sum] = "b8182d43a200fc126a3bf7555626f964"
+SRC_URI[sha256sum] = "5bf004ceffccae881213fb722f34517166b84a34919b92ffc14d1dbd050b71c2"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-requests \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}