aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-13 09:09:38 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-13 18:34:32 -0800
commit94ae616cdaa1d691279805a7035a1109e951786c (patch)
treeada55b739aecd18ce7383530f2284c35e589512a /meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
parent106c94d08688644a619f3231c924cd383054255d (diff)
downloadmeta-openembedded-contrib-94ae616cdaa1d691279805a7035a1109e951786c.tar.gz
python3-bandit: 1.5.1 -> 1.6.2
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb b/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
new file mode 100644
index 0000000000..fa28861e9e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.6.2.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Security oriented static analyser for python code."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "c6a6772d7afa0af8828b3384e73b7085"
+SRC_URI[sha256sum] = "41e75315853507aa145d62a78a2a6c5e3240fe14ee7c601459d0df9418196065"
+
+DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+inherit setuptools3 pypi
+
+RDEPENDS_${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+
+BBCLASSEXTEND = "native"