aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-18 18:22:03 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:56:43 -0700
commit29aaa8b698e3a81f3bf4689fb0ac1678a8e4f0f4 (patch)
tree36a4011684a90d4bc3b363f94e99313f9217a598 /meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb
parent7036ac19bf5103b7cea267131dc6c88fc7c1b709 (diff)
downloadmeta-openembedded-contrib-29aaa8b698e3a81f3bf4689fb0ac1678a8e4f0f4.tar.gz
python3-astroid: Upgrade 2.7.0 -> 2.7.1
Upgrade to release 2.7.1: - When processing dataclass attributes, only do typing inference on collection types. Support for instantiating other typing types is left for the future, if desired. - Fixed LookupMixIn missing from ``astroid.node_classes``. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb b/meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb
new file mode 100644
index 0000000000..4ed051d22d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.7.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "An abstract syntax tree for Python with inference support."
+HOMEPAGE = "https://pypi.python.org/pypi/astroid"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
+
+SRC_URI[sha256sum] = "f3083366b7bb8b3a72c0e12841ab07f14b0d7ff5cc1c89676b84d8f5832e4b61"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES:${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
+"
+
+RDEPENDS:${PN}:class-target += "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-lazy-object-proxy \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-wrapt \
+ ${PYTHON_PN}-setuptools \
+"
+
+RDEPENDS:${PN}-tests:class-target += "\
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+"