aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-09 16:42:23 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commitfec4fa46df1c57ec7e87f940459265bc54cc7dc8 (patch)
tree7b4760b9b01c3fd573492c2c05ced683f76c8c3f /meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb
parent34d7b7c706544d84b78c63eafd2a28c7adf783bd (diff)
downloadmeta-openembedded-contrib-fec4fa46df1c57ec7e87f940459265bc54cc7dc8.tar.gz
python3-astroid: Upgrade 2.6.5 -> 2.6.6
Upgrade to release 2.6.6: - Added support to infer return type of typing.cast() - Fix variable lookup's handling of exclusive statements - Fix variable lookup's handling of function parameters - Fix variable lookup's handling of except clause variables - Fix handling of classes with duplicated bases with the same name Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb b/meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb
new file mode 100644
index 0000000000..10851039b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.6.6.bb
@@ -0,0 +1,32 @@
+SUMMARY = "An abstract syntax tree for Python with inference support."
+HOMEPAGE = "https://pypi.python.org/pypi/astroid"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
+
+SRC_URI[sha256sum] = "3975a0bd5373bdce166e60c851cfcbaf21ee96de80ec518c1f4cb3e94c3fb334"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES:${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
+"
+
+RDEPENDS:${PN}:class-target += "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-lazy-object-proxy \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-wrapt \
+ ${PYTHON_PN}-setuptools \
+"
+
+RDEPENDS:${PN}-tests:class-target += "\
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+"