aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:19 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:56:37 -0700
commit629696b64b93fb94069a440459222f1dd2be56e8 (patch)
treed9b3fb3f3cafd40d62ebbb52de3466c1e2dafd79 /meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb
parent0d539978ad6934f82a4ab064ea680f1b862726b0 (diff)
downloadmeta-openembedded-contrib-629696b64b93fb94069a440459222f1dd2be56e8.tar.gz
python3-astroid: Upgrade 2.3.3 -> 2.4.2
Upgrade to release 2.4.2: - `FunctionDef.is_generator` properly handles `yield` nodes in `While` tests - Properly construct the arguments of infered property descriptors - Handle the case where the raw builder fails to retrieve the ``__all__`` attribute - Restructure the AST parsing heuristic to always pick the same module - Do not crash with SyntaxError when parsing namedtuples with invalid label - Expose a ast_from_string method in AstroidManager, which will accept source code as a string and return the corresponding astroid object - Prevent a recursion error to happen when inferring the declared metaclass of a class Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb b/meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb
new file mode 100644
index 0000000000..677cec7ac0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.4.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "An abstract syntax tree for Python with inference support."
+HOMEPAGE = "https://pypi.python.org/pypi/astroid"
+SECTION = "devel/python"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI[md5sum] = "b54e1325995d3a9abd84bac91d4d5867"
+SRC_URI[sha256sum] = "2f4078c2a41bf377eea06d71c9d2ba4eb8f6b1af2135bec27bbbb7d8f12bb703"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-lazy-object-proxy \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-wrapt \
+ ${PYTHON_PN}-setuptools \
+"
+
+RDEPENDS_${PN}-tests_class-target += "\
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-xml \
+"