aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-03 12:57:55 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-06 10:26:35 -0700
commit72467cbf880df33d358322067caeee515107f42e (patch)
tree67514ff716c05b17dafe84399318c0cc69c74ba1 /meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb
parentbf8ebe03b9548ddf1eefc83df52f34681d28fbe2 (diff)
downloadmeta-openembedded-contrib-72467cbf880df33d358322067caeee515107f42e.tar.gz
python3-asn1crypto: Upgrade 1.3.0 -> 1.4.0
Upgrade to release 1.4.0: - core.ObjectIdentifier and all derived classes now obey X.660 ยง7.6 and thus restrict the first arc to 0 to 2, and the second arc to less than 40 if the first arc is 0 or 1. This also fixes parsing of OIDs where the first arc is 2 and the second arc is greater than 39. - Fixed keys.PublicKeyInfo.bit_size to return an int rather than a float on Python 3 when working with elliptic curve keys - Fixed the asn1crypto-tests sdist on PyPi to work properly to generate a .whl Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb
new file mode 100644
index 0000000000..bb1271e330
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_1.4.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A fast, pure Python library for parsing and serializing ASN.1 structures"
+HOMEPAGE = "https://github.com/wbond/asn1crypto"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7439e38f5e04ff62fae436184786b7ca"
+
+PYPI_PACKAGE = "asn1crypto"
+
+SRC_URI[md5sum] = "00bf5b72d37778e62cc73b1d8909ae27"
+SRC_URI[sha256sum] = "f4f6e119474e58e04a2b1af817eb585b4fd72bdd89b998624712b5c99be7641c"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"